Fix dependency issue when installing from PyPI.

main
Jennifer Taylor 1 year ago
parent 23631564cf
commit 88a340bac1
  1. 3
      arcadeutils/filebytes.py
  2. 1
      requirements.txt
  3. 5
      setup.py

@ -1,10 +1,11 @@
import shutil
from typing import BinaryIO, Dict, List, Optional, Set, Tuple, Union, overload
from typing_extensions import Final
class FileBytes:
IO_SIZE: int = 0x8000
IO_SIZE: Final[int] = 0x8000
def __init__(self, handle: BinaryIO) -> None:
self.__handle: BinaryIO = handle

@ -0,0 +1 @@
typing-extensions

@ -8,7 +8,7 @@ with open(os.path.join("arcadeutils", "README.md"), "r", encoding="utf-8") as fh
setup(
name='arcadeutils',
version='0.1.8',
version='0.1.9',
description='Collection of utilities written in Python for working with various arcade binaries.',
long_description=long_description,
long_description_content_type="text/markdown",
@ -20,5 +20,8 @@ setup(
packages=[
'arcadeutils',
],
install_requires=[
'typing-extensions',
],
python_requires=">=3.6",
)

Loading…
Cancel
Save